Readsoft User's Forum
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
naresh1984

Avatar / Picture

New Member
Registered:
Posts: 5
Reply with quote  #1 
Hi 

I am trying to optimise a quantity field where it should be always one i have tried the below but still it is appearing blank at verify level, can someone suggest

quantity.JPG 


__________________
[biggrin]
0
Ignacio

Senior Expert Member
Registered:
Posts: 62
Reply with quote  #2 
Hi Naresh,

N(1) will tell the system that you want to search for a number with lenght = 1.

If you want to automatically put the value = 1, then you need any autovalue tool in the invoices module, or you could try to do it during the transfer using any of the available user exits.

Hope that helps.

KR

0
naresh1984

Avatar / Picture

New Member
Registered:
Posts: 5
Reply with quote  #3 
Quote:
Originally Posted by Ignacio
Hi Naresh, N(1) will tell the system that you want to search for a number with lenght = 1. If you want to automatically put the value = 1, then you need any autovalue tool in the invoices module, or you could try to do it during the transfer using any of the available user exits. Hope that helps. KR



Hi Ignacio,

I have used this brackets N[1] , where this is suppose to give me the exact value (correct me if i am wrong) Where it used to work under these condition, but the question is why it is not accepting  

__________________
[biggrin]
0
nicothebee

Senior Expert Member
Registered:
Posts: 141
Reply with quote  #4 
Hello,

When you specify N[1], you are not telling the system what value it should capture; you are telling him what format is accepted.
If you have a "2" on your invoice, the system will capture a "2" and complain because this doesn't match the format you have specified.

If it was a single item field, you coould use a vendor field... but this option is not available (as far as I know) for the table items.
The autovalue would do great... if this was a universal rule. But I understand you want this rule to apply only to one vendor...

I have heard of a plugin called "Supplier Rules" that is supposed to apply some business rules per vendor. This may help you...

Best regards,

Nicolás

0
Ignacio

Senior Expert Member
Registered:
Posts: 62
Reply with quote  #5 
Hi Both,

Sorry for my first response Naresh, I didn't see the [ instead of (

I've been working with the [ options because we had a problem in Italy with Purchase Orders that started with SMH or BPO. Our problem was that S used to be interpreted as a 5 and O used to be interpreted as a 0.

We fixed the problem using the following format:  {A[B]A[P]A[O]N(7)|A[S]A[M]A[H]N(7)|N[4]N[5]N[3]N(7)}

That means we are searching a PO starting with BPO, SMH or 453.

Now the funny side, it DIDN'T work with the following format:  {A[B]A[P]A[O]N(7)|A[S]A[M]A[H]N(7)|N(10)}, which means the PO starts with BPO, SMH or is any number of 10 positions, with this format O was read as a 0 and S was read as a 5.

My understanding now is that using [ works fine to force values when interpret "is in doubt", like 5 or S, and O or 0, etc, but to use this you can't allow anything but the values you want it to interpret. N(10) would allow the 5 or the 0 and this is why it failed.

In the other hand, [1] won't work as an autovalue tool to force a value of 1 in quantity, you will need either a user exit during the transfer or any autovalue plug-in as indicated by Nicolas.

You may still have a last chance with eicc.ini file (I would give it a go just in case). In this file you can find the following section:

[AUTOFILL::LINEITEM]
; overwrite existing empty field with the defiend value
; $ = internal application values
; % = transaction description values
; & = line item field
; ^ = user defined variable
; ! = environment variable, e.g. !%COMPUTERNAME%
; @ = concatencate fields
; + = sum amount fields
;Bestell_Nr=Test



I would try adding:

LI_Quantity=1 or
_LI_Quantity=1

This will autofill a 1 for ALL your invoices. If you only want the value to be added for MM invoices (not FI), then you may be able to use the AUTOMODIFY section instead.

If you play with the eicc.ini file (in your globalpath) don't forget to restart transfer service after any modification here.

I hope this may help you, even when it comes to you a bit late ...mmm 6 months now [rolleyes]

Kind Regards.

0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.



Follow @readsoftuser