Readsoft User's Forum
Register Latest Topics
 
 
 


Reply
  Author   Comment  
magelan

New Member
Registered:
Posts: 3
Reply with quote  #1 
Hello,

I try in manager in the  Automatic configuration module value to retrieve the supliernumber but it does not work . screenshot to follow.

axe7.png 

I also tried to set the insertion of the value the sql database but it  does not work either screenshot.

  cptgen.png    
I have less information about ReadSoft self-help forum that share

sory for my bad English

Thanks for your help






0
cherylc

Moderator
Registered:
Posts: 161
Reply with quote  #2 
Hi,
Welcome to the forum!
I will see if I can locate some doco on auto value configuration when I am back in the office on Monday. In the mean time, did you close and restart the Interpret and Manager services after the change?
Kind regards

__________________
Cheryl
LinkedIn: https://au.linkedin.com/in/cherylc-651471a0
0
cherylc

Moderator
Registered:
Posts: 161
Reply with quote  #3 
Hi
I checked our settings this morning. We are not populating a variable using the autovalue configuration tool. We only use it to populate a fixed value. So just guessing here (apology).  There are some notes in Invoices Help (search for autovalue add on).

Some things you can try are:

1.  Close and restart the Interpret and Manager services after each change.
2.  Check that you have the field SupplierNumber in the Transaction Description.
3.  For the database configuration. The database must be SQL not an Oracle database.  Check your autovalue configuration ini file.  There are some settings concerning autovalue configuration (see below). Check UseThisFile value.  Check database login credentials.  Note that sa means System Administrator.  So check that you have the correct password for sa.

A word of warning when using an sa login in configuration.  When the real system administrator changes the system password, Readsoft services stop working.

Autovalue configuration ini file is stored in Bin Directory (like this).
[image]


autovalue configuration.png


__________________
Cheryl
LinkedIn: https://au.linkedin.com/in/cherylc-651471a0
0
cherylc

Moderator
Registered:
Posts: 161
Reply with quote  #4 
Hi again,
I edited my answer above after running a test in our Test environment.  In using similar settings as yours (in the first screenshot) I was able to successfully populate a field with the supplier number.

Here are my settings:
autovalue configuration.png 
Note that when I restart Manager/Interpret, the value in macros field disappears.

So I think the choices are:

1.  Change requires a restart of Interpret module, or
2.  There was a value in the field of the test invoice, or
3.  There is no SupplierNumber in transaction description

In relation to your Option 2 to obtain the value from the database, there is potentially a user access issue. 

Hope this helps.
Kind regards


__________________
Cheryl
LinkedIn: https://au.linkedin.com/in/cherylc-651471a0
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.



Follow @readsoftuser